6.13. Menu: File

6.13.1. Open Laser Show

Fig.58 menu file
Fig.58: Menu Background Image.

This automatically opens the Timeline and the Windows standard dialog for opening a file. Select the desired, already existing laser show and it is loaded to the timeline. When doing so, the active show folder changes to the one of the new laser show – and so do the figures in the Figure Table. So save your work prior to opening a laser show.

 

6.13.2. Play-List Load

This automatically opens the Timeline and the Windows standard dialog for opening a file. Select the desired, already existing Playlist. It loads in a new playlist window and is ready to use.

 

6.13.3. Load Live Show

This menu item opens a dialog for loading an already existing live show. The Live Window automatically opens on loading the show.

 

6.13.4. New Figure

This menu item does the same as the “New Figure”-button (see chapter 6.2.1) – it creates a new figure.

 

6.13.5. Sav, Save As, Save All

These menu items do the same as the “Save”-, “Save As” and “Save All”- buttons (see chapter 6.5.1, 6.5.2, 6.5.3): They offer different saving options for figures.

 

6.13.6. Delete File

“Delete File” can be used for deleting the active figure. It is deleted from the hard disc and thus also disappears from the Figure Table. On deleting a figure, the Figure Table is reloaded.

 

6.13.7. Import ILDA

The “Import ILDA” menu item is used for importing ILDA files (*.ild) to Laserworld Showeditor. 2D and 3D ILDA files can be imported as well as ILDA files with or without color table or RGB data. On import, the ILDA files will be converted to the Showeditor file format, so they become editable in Laserworld Showeditor.

Importing ILDA-files can cause issues in rare cases, as the “ILDA Standard” is not always respected by every programmer – some *.ild files do not provide the standardized protocol in full or come with additional information that is not meant to be included. In such a case a message with further detail is displayed.
However, Utmost imports of ILDA files work very well.

Supported ILDA standard file format is any version up to version 5.

Information:
Depending on the program they have been created with, some ILDA files are defective, as the storage byte order for the colors is red – green - blue instead of the correct blue - green – red. If blue and read appear to be swapped, change the color order in Options -> Others. This setting applies for the import as well as for the export of ILDA files.
Many existing ILDA files use the Pangolin color table. If this is the case, load the Pangolin color table first (Color-table) and then convert to Laserworld Showeditor colors (Windows -> Special features - > Change color handling to Showeditor color table values)

 

6.13.8. Save ILDA

Export a figure as ILDA-file (*.ild) using this menu item. This only works for figures you have the permission to export. Export permissions can be set in Options -> Default Rights Settings

Fig.59 defaul right settings
Fig.59: Options -> Default Rights Settings: Set the file and figure access rights

Important:
On using the ILDA export feature, only the basic coordinates are exported. An optimization or interpolation is not done. If this is required or if a complete show shall be exported, use the show export feature File -> Export Show as ILDA-File.
Different ILDA-formats are offered for export. The recommended one is: Type 5 ILDA-file (RGB). Please consider that not every program can read every ILDA-format correctly.

 

6.13.9. Import *.AI file (Adobe Illustrator)

It is possible to import Adobe Illustrator (*.ai) files to Laserworld Showeditor. Drawings made in Adobe Illustrator or Corel Draw are saved as vectors – so they have the same characteristics as ILDA files have.
It is important to use *.ai files in the correct file version, as not every version can be imported to Laserworld Showeditor. It is also essential that only true vectors are used in the *.ai file, as e.g. colored areas or color transitions in areas can of course not be properly imported. Line-only drawings are the best choice for import. If the elements of the *.ai file are not compatible vectors, the import may fail.

 

6.13.10. End

A click on this menu item closes the program.

 

6.13.11. Entries below "End"

This list shows the history of the 10 most recently loaded laser shows (*.shw) or playlists (*.pll). This allows for quick access to the last used files.